1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

problème configuration des moteurs

Discussion dans 'Mach' créé par barco00, 20 Décembre 2012.

  1. barco00

    barco00 Nouveau

    Messages:
    13
    Inscrit:
    27 Avril 2012
    problème configuration des moteurs
    Bonjour tout le forum,

    la configuration de mes moteurs me joue des tours,
    quand je demande a mach3 de se déplacer de 50mm via le mdi, lil le fait en G0 mais il me fait +- la moitier en G1 :sad:

    voila ma carte et sa config :

    Carte CNC FA-01/2006, partie puissance suivant le schéma publié par Pierre Rouzeau.

    Fonctions :
    - 4 sorties pour moteurs bipolaires 2A/phase PWM, mode 1/2pas, slow decay, tension maxi 32V
    - 1 sortie relais 250V/10A
    - 4 entrées digitales
    - 1 horloge 2 kHz pour logiciel de découpe au fil chaud GMFC

    --------------------------------------------------
    Partie driver + horloge :

    74LS541 1x
    NE555 1x
    7805 1x
    7812 1x
    1k 1/4W 5x
    33K 1/4W 1x
    1M trimmer 25tr 1x
    470pF céramique 5mm 1x
    10nF LCC 5mm 1x
    10µF chimique radial 5mm 63V 2x
    Connecteur DB25 male coudé 1x
    Support DIL8 1x
    Support DIL20 1x
    Picot à souder pas 2.54, 2 pins 6x
    Picot à souder pas 2.54, 3 pins 3x
    Cavalier pas 2.54 3x

    --------------------------------------------------
    Partie relais :

    10k 1/4W 1x
    1N4148 1x
    BC548 1x
    Relais Finder série 36V 12V - 10A/250V 1x
    Bornier 2 points à visser pas 5mm 1x

    --------------------------------------------------
    Partie puissance (4X) :

    L6208 DIL24 1x
    1 1/2W metal 5% 8x
    100 1/4W 1x
    1k 1/4W 1x
    4k7 1/4W 1x
    6k49 1/4W 1x
    51K 1/4W 2x
    1k trimmer 25tr 1x
    1N4148 2x
    1nF céramique 5mm 2x
    10nF céramique 5mm 1x
    47nF LCC 5mm 1x
    100nF LCC 5mm 2x
    220nF LCC 5mm 1x
    470µF chimique radial 5mm 63V 1x
    Bornier 4 points à visser pas 5mm 1x
    Support DIL24 tulipe contact doré 1X
    Dissipateur RA23 (profilé U 16x145x11) 1X

    --------------------------------------------------
    Quelques indications :

    La carte doit impérativement être étamée à chaud.
    Les pontages de la puissance (alimentation vers L6208, sorties vers moteurs) se font sous la carte.
    Chaque pontage peut passer par un interrupteur pour couper chaque moteur indépendamment.
    Ne surtout pas oublier oublier les pontages du 5V vers les L6208 !!!!
    Le dissipateur est monté sur les L6208 à la pâte silicone, et est ventilé par 1 ou 2 ventilateurs 80x80.
    Sa fixation est assurée par 2 écrous M2 + 2 tiges filetées M2 soudées sur la masse entre les L6208.

    Réglage intensité (Vref, moteur non connecté, 0.25V / A) :
    0.60V -> 2.4A
    0.50V -> 2.0A
    0.40V -> 1.6A
    0.25V -> 1.0A
    0.20V -> 0.8A

    Paramétrage des cavaliers :
    - cavalier seul, mis côté :
    - NE555, active l'envoi vers le PC du timer 2kHz
    - DB28, active le 4ème fin de course
    - paire de cavaliers, mis côté :
    - puissance : synchronize la partie puissance n°4 avec la n°1 (double motorisation X sur fraiseuse)
    - 74LS541 : partie puissance n°4 indépendante

    Paramétrage du logiciel de pilotage :
    Broche (pin) Fonction 'Fil chaud' Fonction 'Fraiseuse'
    - pin 1 relais relais
    - pin 2 dir Y gauche dir X
    - pin 3 step Y gauche step X
    - pin 4 dir X gauche dir Y
    - pin 5 step X gauche step Y
    - pin 6 dir Y droit dir Z
    - pin 7 step Y droit step Z
    - pin 8 dir X droit dir A (si axe n°4 indépendant)
    - pin 9 step X droit step A (si axe n°4 indépendant)
    - pin 10 sortie timer palpeur outil
    - pin 11 fin de course X
    - pin 12 fin de course Y
    - pin 13 fin de course Z




    [​IMG]


    je voudrais savoir si mes calcules sont justes :
    donc j'ai des moteurs de 200 pap par révolution, des vis métrique de 12mm avec un p de 1.75,on ma conseiller de travailler en micro p
    voila mon calcul : 2000/1.75*2= 2285.714285
    pourquoi fois deux ? parce que ma carte est configurée en demi p

    meci de m'aidé sa serrai sympa
     
  2. barco00

    barco00 Nouveau

    Messages:
    13
    Inscrit:
    27 Avril 2012
  3. valentin

    valentin Compagnon

    Messages:
    608
    Inscrit:
    30 Juillet 2008
    Localité:
    pas de calais france
    problème configuration des moteurs
    bonjour
    si en Mdi tu as une difference de deplacement
    entre avance G1 et G0 ce quil y a perte de pas en G0
    diminue ta velocite

    ++
     
  4. barco00

    barco00 Nouveau

    Messages:
    13
    Inscrit:
    27 Avril 2012
    problème configuration des moteurs
    Bonjour Valentin,
    je te remercie pour ta réponse,
    le calcule est bon ?
    avoir une différence pareil, sa serrai la vélocité ?
    je vais la décendre pour testé

    merci à toi
     
  5. barco00

    barco00 Nouveau

    Messages:
    13
    Inscrit:
    27 Avril 2012
    problème configuration des moteurs
    Bonjour valentin,
    je vient de faire les tests que tu ma mis et en Y tout fonctionne a merveil en G0 comme en G1
    mais pour l'axe X quand je lui demande de se déplacer de 50mm en G0 c'est nikel mais en G1 il se déplace de 25,36, donc de plus ou moin la moitier


    d'où peut venir le problème ??

    :oops: :oops:
    merci pour ton aide
     
Chargement...

Partager cette page