1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Premiere utilisation arduino + easydriver + moteur PaP

Discussion dans 'Electronique spécifique CNC' créé par vibram, 27 Mars 2016.

  1. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    Bonjour à tous et joyeuse pâque !

    Je commence tout juste à utiliser l'ensrmble arduino + easydriver + moteur PaP car j'en avais dans une caisse
    Le postulat: je n'ai aucune connaissance en électronique ni électricité
    Pour débuter je me contente donc de reproduire des schémas simples pour comprendre les grands principes
    Je me suis donc lancé la dedans
    https://www.sparkfun.com/tutorials/400

    Cependant cela ne fonctionne pas.
    J'ai pris la tension (terme exact?) au bornes pwr in et grd de mon easy driver et j'ai 4.15 ce qui me semble correct
    En revenche j'ai 0.02 sur les pin A+/- et 0.01 surB+/- de ma carte easy driver
    Je suppose que le problème vient de la?
    les soudures ne sont pas parfaites mais je n'ai pas limpression qu'il y ait de court circuit pour autant...
    A noter que la LED 5v du driver est allumée lorsque l'alim est branchée
    Bref je bloque un peu. Merci pour votre aide !
     
    Dernière édition: 27 Mars 2016
  2. Didier-CN

    Didier-CN Apprenti

    Messages:
    99
    Inscrit:
    26 Mai 2014
    Localité:
    Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    Bonjour,

    Poster une photo de l'ensemble câblé me semble un minimum pour donner un 1° avis.

    Le programme a-t-il bien été chargé dans l'Arduino?
     
  3. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    Il n'y a que les pins du moteur pour lesquelles j'hésite j'ai un peu essayé tous les sens /ordre sans succès P_20160327_175336.jpg
     
  4. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    Voici la version qui me semblait être correcte mais sans succès
    A noter que j'ai pris la tension aux bornes de l easy driver et pas aux bornes du moteur P_20160327_175640.jpg
     
  5. Didier-CN

    Didier-CN Apprenti

    Messages:
    99
    Inscrit:
    26 Mai 2014
    Localité:
    Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    Le câblage n'a pas l'air brouillon, et autant qu'on peu en juger conforme aux indications de sparkfun, qui m'ont l'air correctes à 1° vue.

    1° problème: l'alimentation se fait via une prise USB. Il y a fort à parier qu'elle est insuffisante pour le moteur. La tension risque de s'effondrer dès que le moteur va consommer. 4,15V, c'est déjà bas.

    Il faut alimenter l'Arduino par sa prise jack (7 à 12V), la carte va générer du 5V.

    Avant de mettre sous tension, identifier à l'ohmmètre les bobinages du moteur. Connecter ensuite le moteur en fonction de cela: 1 bobinage sur les bornes A, l'autre sur les bornes B. Ça a peu d'importance pour un test à vide.

    Il serait bon d'en savoir un peu plus sur le moteur. A-t-il une étiquette?
     
  6. gégé62

    gégé62 Compagnon

    Messages:
    1 380
    Inscrit:
    26 Février 2013
    Localité:
    Harnes (Pas de Calais)
    Département:
    62440
    Premiere utilisation arduino + easydriver + moteur PaP
    bonjour,
    je démarre moi aussi en ce moment avec ce genre de manip Arduino+moteur PAP
    Moteur PAP à 4 fils, en principe c'est donc du pipolaire, c'est à dire 2 bobines indépendantes (disposées à 90°) que l'on alimente tour à tour, et en inversant une fois sur deux le sens de l'alim.
    As-tu déja bien repéré tes bobines à l'ohm-mètre ? la disposition que tu montres semble logique, mais c'est si facile de tester.

    Au niveau du programme, ce serait étonnant qu'il y ait un bug, mais je suis étonné qu'il n'y ait pas un "delayMicroseconds(xxx)" entre la commande
    digitalWrite(steppin, LOW) et
    digitalWrite(steppin, HIGH), tout comme il y en a un après la mise à HIGH.
     
  7. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    Merci pour vos reponse
    J'ai conservé le meme branchement en alim externe, j'ai presque 12v à l'entrée du driver mais toujours 0 en sortie
    Je me demande si je n'ai pas brulé qqch avec mes soudures de bourin...
    Je vais regarder sur internet pour savoir comment on teste le bobinage. Je n'ai aucune inscription sur les moteurs malheureusement
     
  8. Didier-CN

    Didier-CN Apprenti

    Messages:
    99
    Inscrit:
    26 Mai 2014
    Localité:
    Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    Ne pas prendre mal cette remarque, mais bricoler de l'électricité/ électronique sans avoir de notion aussi basique et en se basant sur internet, c'est un peu comme essayer de piloter un avion après avoir joué à un jeu vidéo.

    Pour ne pas perdre trop de temps et ne pas faire de dégâts (voire se mettre en danger), il vaut mieux se faire accompagner par un ami (du vrai monde, pas de fesse-bouc). On pourra éventuellement aider, mais ça ne sera pas simple.

    http://edusofad.com/www/demo/wscp-4011/demo/q1s307.php

    Débrancher obligatoirement le moteur.

    Quand la résistance sera infinie, c'est que la mesure sera faite entre 2 pôles de 2 bobinages différents. Quand elle sera faible, c'est que ce sera les 2 pôles d'un même bobinage.

    Si on ne trouve que des résistances basses dans tous les cas de figure, le moteur est en court-circuit.

    Si on trouve toujours l'infini, c'est que les bobinages sont coupés.

    Et si on met les doigts, on mesure la résistance du corps humain dans les cas où on devrait trouver une résistance infinie.
     
  9. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    J'ai de très vagues restes de l'école ainsi que l'aide ponctuelle de mon père.
    Je pense avoir réussi a identifier les deux bobinages (la valeur passait de 0 à X selon les bornes choisies, j'en conclue que la meme bobine était lorsque la valeur devenait X

    Je ne prends pas mal cette remqrque. C'est juste que quand on est issu d'un monde totalement différent, ce n'est pas évident de trouver les personnes qui ont les compétences et l'envie d'aider. Résultat j'essaie de me débrouiller par moi même...

    Je vais tester avec mon autre driver, histoire de...
     
  10. Didier-CN

    Didier-CN Apprenti

    Messages:
    99
    Inscrit:
    26 Mai 2014
    Localité:
    Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    Exact.

    NB: j'ai édité et complété mon message précédent
     
  11. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    Eureka.
    Donc c'est donc bien le driver qui ne fonctionne pas correctement. Ca ne m'etonne qu'a moitié car je n'avais qu'un enorme fer à souder, pas du tout adapté à mon utilisation...
    Je vais voir pour acheter un fer un peu mieux et essayer de reprendre les éléments du driver defaillant.
    Merci pour le coup de main, j'ai appris de nouvelles choses !
     
  12. Fred69

    Fred69 Compagnon

    Messages:
    2 782
    Inscrit:
    2 Décembre 2008
    Localité:
    F-69 sud-ouest Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    J'en connais, quand ils doivent planter un clou, il leur faut un disciple pour tenir le clou, un autre pour le marteau.
    Le mieux c'est d'apprendre à se débrouiller seul. Enfin, c'est mon avis.
    Ou alors, c'est la bonne excuse pour ne rien faire "on ne m'a pas expliqué".
     
  13. Didier-CN

    Didier-CN Apprenti

    Messages:
    99
    Inscrit:
    26 Mai 2014
    Localité:
    Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    Un petit lien pour la soudure:
    http://www.sonelec-musique.com/electronique_bases_tutoriel_soudure.html

    Fred, on ne peut simplement pas comparer planter un clou et se frotter à l'électricité et l'électronique. D'une part, il y a quand même un minimum de bases théoriques à assimiler, d'autre part avec un marteau et un clou, on ne risque que son doigt (ou si on est prévoyant, celui du disciple :-D). Avec l'électricité ou l'électronique, les conséquences peuvent être plus lourdes.
     
  14. Fred69

    Fred69 Compagnon

    Messages:
    2 782
    Inscrit:
    2 Décembre 2008
    Localité:
    F-69 sud-ouest Lyon
    Premiere utilisation arduino + easydriver + moteur PaP
    Tu sais, j'ai appris à bricoler seul. Si j'avais dû attendre qu'on m'explique, peut-être que j'attendrais encore.
    Par contre, une chose importante: apprendre à évaluer les risques.
     
  15. vibram

    vibram Compagnon

    Messages:
    780
    Inscrit:
    15 Mars 2014
    Premiere utilisation arduino + easydriver + moteur PaP
    j'ai quand meme appris les bases comme ne jamais opérer sous tension etc.
    S'il y a bien quelque chose ou je fais attention; c'est pour la sécurité.
    Apres ca ne m'empeche pas d'essayer si je considère que le risque est limité.
     
Chargement...

Partager cette page