1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Ninos: Problème de compatibilité

Discussion dans 'Ninos' créé par cncsiste, 14 Novembre 2012.

  1. cncsiste

    cncsiste Apprenti

    Messages:
    114
    Inscrit:
    3 Novembre 2012
    Ninos: Problème de compatibilité
    bonjour,
    j'essaie de faire fonctionner l'ensemble de la photo avec Ninos, l'axe des X ça va l'adressage des Pins est cohérent, Y aussi mais ça commence a paraître bizarre, mais alors le Z y a pas moyen.
    J'ai pensé à une panne de la carte, j'ai fait un test avec Mach3 et là, ça fonctionne.
    Si quelqu'un peut m'aider je le remercie d'avance

    bis P1070562.jpg
     
  2. psemel

    psemel Ouvrier

    Messages:
    273
    Inscrit:
    21 Mars 2009
    Localité:
    oise
    Ninos: Problème de compatibilité
    bonsoir,

    il y a une liste de diffusion NINOS sur yahoo.

    qu'elle est la version de ninos?

    c'est surrement un mauvais parametrage.
     
  3. cncsiste

    cncsiste Apprenti

    Messages:
    114
    Inscrit:
    3 Novembre 2012
    Ninos: Problème de compatibilité
    bonsoir,
    ma version Ninos est assez ancienne V3.81, j'arrive à la paramètrer avec une Breakout que j'ai faite moi même à base de 74LS541,
    le boîtier bleu j'ai réussi à le faire avec le Mach3 par contre avec Ninos, j'ai l'impression que j'ai besoin de 3 fils ! enfin 1 de plus que le Dip et le Steep traditionnel
    je vais faire des tests pour en avoir confirmation
    merci
     
  4. psemel

    psemel Ouvrier

    Messages:
    273
    Inscrit:
    21 Mars 2009
    Localité:
    oise
    Ninos: Problème de compatibilité
    bonjour.

    je ne connais pas ta carte, mais chez moi j'ai cette configuration sur le port //
    X Y Z A
    step 3 5 7 9
    dir 2 4 6 8

    Les autres entrée sont les butées.

    Verifier egalement le cable // et la documentation de ta carte.

    Verifie egalement la vitesse et la rampe d'acceleration de l'axe incrimminé qui est peut etre trop forte.
     
  5. cncsiste

    cncsiste Apprenti

    Messages:
    114
    Inscrit:
    3 Novembre 2012
    Ninos: Problème de compatibilité
    bonjour,
    merci de m'aider, voilà deux tableaux avec mes réglages, un pour Mach3 qui marche correctement sous cette configuration malgrés que cela puisse paraître bizarre, et l'autre avec Ninos, le moteur des X fonctionne très bien, le Y aussi bizarrement que cela puisse paraître c'est moins fluide que le X! quand au Z alors là tintin pas moyen de le faire tourner quelque soit la broche attribuée sur cet axe
    Mach3.jpg
    Ninos.jpg
     
  6. psemel

    psemel Ouvrier

    Messages:
    273
    Inscrit:
    21 Mars 2009
    Localité:
    oise
    Ninos: Problème de compatibilité
    bonsoir,

    dans la deuxieme photo tu n'a pas de mis les pins pour l'axe Z , c'est peut etre normal!

    as tu changer de port LPT pour voir?

    as tu essayer les affectations donnée ce matin?

    x : pas 3 dir 2
    Y : pas 5 dir 4
    z : pas 7 dir 6
    a : pas 9 dir 8
     
  7. cncsiste

    cncsiste Apprenti

    Messages:
    114
    Inscrit:
    3 Novembre 2012
    Ninos: Problème de compatibilité
    bonsoir,
    j'ai rien mis dans les cases pour l'axe des Z parce que j'ai rien trouvé qui fonctionnait,
    j'ai essayé plusieurs PC avec des ports parallèle comme ça c'était plus sur
    j'ai mis les réglages que tu conseillais pour les trois axes, j'ai le Y qui fonctionne seulement en Steep pas de Dir, j'ai neutralisé toutes les broches des axes X et Z (inutilisées) et j'ai essayé toutes les possibilités pour avoir le Dir sur l'axe Y et là il n'y a plus rien qui fonctionne je n'ai même plus le Steep sur cet axe je suis obligé d'affecter les broches sur les axes X et Z pour que le Y marche (mais seulement le Steep),
    c'est pour ça que je disais plus haut que j'ai l'impression d'avoir besoin de trois broches pour faire aller un moteur
    bonjour le mal de tête
     
  8. psemel

    psemel Ouvrier

    Messages:
    273
    Inscrit:
    21 Mars 2009
    Localité:
    oise
  9. cncsiste

    cncsiste Apprenti

    Messages:
    114
    Inscrit:
    3 Novembre 2012
    Ninos: Problème de compatibilité
    bonjour,
    avec la boîte CNC Controller j'ai eu un petit disque, il y a pas mal de choses dessus (enfin tout ce qui concerne le vendeur)
    je vais chercher ce qui a trait à ma carte, mais j'ai un peu l'impression que c'est par rapport à Ninos qu'il y a un problème, là je suis déjà occupé avec j'ai encore changé de PC et je vais faire des tests avec EMC2 de LINUX pour voir si j'arrive à attribuer les sorties correctement
    ça me travaille tellement que j'ai même bricolé unefiche de port parallèle pour changer le cablage comme j'ai envie
    merci pour ta proposition en MP, je vais encore faire des essais afin d'avoir une petite expérience qui me permettrais plus tard de répondre à des questions précises

    P1070612.jpg
     
Chargement...
Articles en relation
  1. hcoyote
    Réponses:
    4
    Affichages:
    915
  2. MrDUS31
    Réponses:
    4
    Affichages:
    2 841
  3. ewok2
    Réponses:
    0
    Affichages:
    705
  4. veyrine
    Réponses:
    5
    Affichages:
    2 493
  5. yaatus71670
    Réponses:
    2
    Affichages:
    825

Partager cette page