1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Message erreur "M08 interdit, Broche à l'arrêt"

Discussion dans 'Num' créé par bac_tu, 31 Janvier 2012.

  1. bac_tu

    bac_tu Nouveau

    Messages:
    5
    Inscrit:
    31 Janvier 2012
    Message erreur "M08 interdit, Broche à l'arrêt"
    Bonjour,

    Je suis enseignant en productique dans une lycée professionnel et je suis confronté a une erreur de la part de mon centre d'usinage centromab num750.

    Lorsque je met M08 dans un programme ISO (marche pompe lubrifiant) j'ai un message d'erreur du calculateur lorsque qu'il arrive à la lecture de la ligne où est présente cette fonction :

    "M08 interdit, broche à l'arrêt"

    Mes déplacements s'effectuent correctement, mais sans la pompe ni la broche en marche.

    Cette erreur se répète quasi systématiquement à chaque cycle. Ou si mon programme fait appel à 2 outils (exemple, forêt à pointer + foret à percer) il y a souvent l'un ou l'autre outil qui ne tournera pas, ou les 2.

    Si j'enlève la fonction M08 partout dans mon programme tout se passe bien.

    j'ai essayé de déplacer le M08 dans mon programme :
    M8 sur la ligne de changement outil;
    M8 sur la ligne de mise en marche broche
    M8 sur le premier point d'approche;

    Rien n'y fait.

    Si vous avez rencontré cette erreur je suis preneur...
    Merci de votre aide.
     
  2. usi64

    usi64 Compagnon

    Messages:
    659
    Inscrit:
    10 Juillet 2009
    Localité:
    Pau 64
  3. bac_tu

    bac_tu Nouveau

    Messages:
    5
    Inscrit:
    31 Janvier 2012
    Message erreur "M08 interdit, Broche à l'arrêt"
    PROBLEME RESOLU.

    Problème initial rappel :
    la broche ne se mettait pas en marche quelque fois, et de façon aléatoire. Soit en tant que 1er outil utilisé du programme, soit en tant qu'outil N°xx dans un quelconque programme.
    le M08 n'est pas en cause. Ni la façon de programmer.

    Je me suis attelé à trouver cette panne chiante et je vais vous en expliquer les grandes lignes.

    Matos :
    Notice du centromab, manuel de câblage.

    Procédure de diag, rappels divers :

    Une machine c'est quoi ?
    Un cerveau nommé calculateur. A ce calculateur on relie des capteurs mécaniques, optiques, inductifs etc... qui informent sur l'état ou la position des éléments mécaniques/électriques/pneumatiques, ainsi que divers éléments qui commander des accessoires : électrovannes, contacteurs électriques, pompes, ....

    Les capteurs qui donnent une info au calculateur sont branchés sur la "carte des entrées NUM"
    Les "sorties" qui commandent les relais des contacteurs électriques de pompes, électrovannes, "sont câblés sur la carte des sorties NUM"

    Il faut savoir que pour qu'une machine se mettent en mouvement, il lui faut certaines infos données par les capteurs, et qu'une fois qu'elle a toutes les valeurs qui lui sont nécessaires, le calculateur active les "sorties" et tout marche comme sur des roulettes.

    Dans mon cas ici, je n'avais pas la broche qui tournait, de façon aléatoire.
    Donc ? il lui manquait une info ou plusieurs, pour pouvoir activer la sortie correspondante au contacteur du moteur de broche.

    ETAPE DE DIAG en état de marche:
    Je lance un cycle, tout va bien.
    je met le potard des avances à 0
    et je passe en mode "extenpage" "paramètre automate"
    Ici je prend la notice de la machine partie schéma de câblage des entrées, et je vais interroger le calculateur sur l'état des entrées (donc l'état 0 ou 1 des différents capteurs)
    Certains seront à l'état "0" d'autres à l'état "1"
    Et la je m'attaque à taper : E.1 E.2 E.3 etc ....puis LF en prenant en compte toutes les entrées possibles spécifiées dans la notice de cablage. j'en arrive a une 30 aines de capteurs.
    La machine me sort les états : E.1 0 ; E.2 1; E.3 0; etc... je note tout sur un papier.
    J'ai donc un état de tous mes capteurs d'entrée, lorsque tout va bien.

    Ensuite et c'est là que j'ai galéré, j'ai du attendre sagement cycle après cycle que la machine se mette en défaut.... et bien sur c'est quand on a besoin qu'elle tombe en panne exprès, qu'elle marche plutôt bien... ARG !! Mais mon acharnement à payé, elle a fini par tomber en panne, donc a ce que la broche ne se mette pas en marche.

    Et la rebelote, j'interroge de nouveau tous les capteurs avec la même procédure, et je note les états 0 ou 1 de chacun d'eux.
    Et la.... miracle, il y a 2 capteurs qui n'ont pas le même état que lorsque tout marche. (exemple capteur E.14 et E.15)
    je regarde sur la notice, et je cherche sur le schéma de câblage la définition de ces 2 là.

    E.14 : rotation broche M3 (tu m'étonne qu'il ne soit pas activé la broche tourne pas !! normal quoi) lui il ne sert que d'info a priori.
    E.15 : il n'est même pas câblé sur mon schéma l'enfoiré, donc je ne sais pas ce que c'est ! tout ce que je sais c'est qu'au lieu d’être a 1 il est a 0 !
    Ce qui signifie que la machine attend que sa valeur passe à 1 (activé) pour donner l'ordre à la broche de tourner....

    Bon ben il me reste qu'a le trouver sur la machine en jouant à cache cache avec lui.
    Je vois sur le schéma de câblage, que le fil du capteur E.15 est relié à la borne N°13 de la carte des entrées NUM N°1.

    J'ouvre une armoire électrique du le coté de la machine, je cherche où c'est indiqué "cartes entrées NUM N°1", et je localise sur le bornier le Numéro 13. jusque là fastoche. Effectivement il y a un fil dessus.
    Je chope le fil et je le suis dans l'armoire et les goulottes de câbles, c'est assez facile car chaque fil est repéré par un numéro, ici le N°27. je suis, je suis il arrive dans une grosse gaine de fils, je suis la gaine..... et cette gaine arrive dans un coffret électrique dans la tête de la machine au dessus de la broche.

    Je dégage le carter de la tête de la machine, qui je vous le rappelle est toujours en "pause".
    J'ouvre le coffret électrique, et je découvre un beau bornier de câbles. Arrive à ce bornier la grosse gaine de fils qui vont à la carte des entrées, et sont branchés à ce bornier, une flopée de capteurs qui sont à différents endroits autour de la tête de la machine.

    Je repère le fil N°27 branché au bornier 10 et je trouve donc en rapport un fil de capteur, que je vais suivre avec application car c'est au bout de ce fil que se situe enfin mon PROBLEME !!!!!

    Effectivement en 2 min je vois direct ou ca me mène : CAPTEUR TYPE POUSSOIR MECANIQUE, concernant l'indexage de la broche.
    Traduction :
    CAPTEUR ACTIVE = ETAT 1 = SIGNIFIE QUE LA BROCHE N'est PLUS INDEXEE, donc verrouillée, donc la CN peut l'activer en rotation.
    CAPTEUR NON ACTIF = ETAT 0 = Signifie que la broche est indexée (pour un changement d'outil par exemple) et donc la CN n'envoie pas de commande en rotation, sinon adios l'index de mise en position !

    C'est un petit verin pneumatique qui indexe la broche. CE capteur informe juste de la position de l'index de ce vérin :
    Verin sorti, capteur non actif = broche indexée
    Verin rentrée, capteur actif = broche libre, prête à tourner.

    MAIS MAIS que se passe t'il car je voit bien que le capteur est enfoncé, donc activé !! pourtant à l'écran E.15 = 0 (au lieu de 1)

    Solutions possibles :
    Câblage défaillant, fils pas bien serrés (25 ans de vibrations...)
    Capteur entrain de mourir
    Capteur mal positionné.

    Il me prend une envie subite d'insérer mon réglet entre le téton du capteur mécanique et la pièce qui est censée appuyer dessus.... et la... miracle E.15 passe à 1 et la broche se met en marche.... !!!!
    YOUPI !! en faite le capteur avait bougé, car ses 2 petites vis de fixation s'étaient desserrées.... 25 ans de vibrations avaient joué... je resserre le capteur et après des 10aines d'essais, je peux confirmer que ça venait bien de la.

    A cause d'une petite vis de M4 j'ai été emmerdé au plus haut point en perdant des heures et des heures pensant que ça venait de la programmation... alors que c'était juste un capteur qui avait pris du jeu et qui aléatoirement ne donnait plus la bonne infos au calculateur.

    Le principe de diag est ici applicable a tous les calculateurs. Attention cependant aux machines récentes, tout est centralisé sur des cartes informatiques difficiles à comprendre et dont chaque élément n'est pas facile à identifier. Et je passe sur la fragilité des composants électroniques.

    En espérant que ça peut aider certains opérateurs.
     
Chargement...
Articles en relation
  1. sm27340
    Réponses:
    0
    Affichages:
    688
  2. roboba
    Réponses:
    8
    Affichages:
    175
  3. lionel33
    Réponses:
    7
    Affichages:
    811
  4. truck18
    Réponses:
    11
    Affichages:
    1 247
  5. pcng
    Réponses:
    1
    Affichages:
    667

Partager cette page