1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  1. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Ma CNC 6040
    Salut à tous !

    Voilà quelques mois que je traine sur le forum en postant quelques fois de petits mots en attendant l'arrivée et l'installation de ma fraiseuse (routeur). :)

    Elle est donc là !!! Modèle 6040 avec un 4ème axe et broche de 800W à refroidissement liquide.
    [​IMG]


    Après déballage, finition du montage (elle arrive en 2 parties) et maintenant réglages (que j'ai pas encore fini)...

    J'ai une question pour les pros de MACH3 : dans mes réglages, j'en suis aux moteurs, et je n'arrive pas à avoir un fonctionnement correct, je m'explique. :???:
    J'ai des moteurs pas à pas de ref 57BYGH636 avec un pas de 1.8° et 3A de fonctionnement.
    Dans MACH3, j'ai donc mis 400 micros pas, 2500 pour la vitesse et ai mis une accélération à environ 0.15 sur le graphique.
    Lorsque je déplace mes axes en manuel, mes moteurs grognent, j'ai donc inversé le pas à 0 dans la configuration des moteurs.
    ça va mieux, sauf qu'après quelques mouvements, ça recommence !!! :shock:
    Après plusieurs essais, je ne sais plus quoi faire, car quelque soit la vitesse ou l'accélération que je mets, tantôt ça marche quelques instants, tantôt les moteurs broutent de suite.
    J'ai même tout éteint et relancé, mais idem... :cry:

    Je me demande si il n'y a pas un truc à toucher sur les cartes de contrôle ou autre.
    Vous en pensez quoi ?
     
  2. minas

    minas Nouveau

    Messages:
    7
    Inscrit:
    21 Décembre 2010
  3. ctoutmoi

    ctoutmoi Ouvrier

    Messages:
    479
    Inscrit:
    15 Janvier 2008
    Localité:
    Cabries (A côté d'Aix en Provence...)
    Ma CNC 6040
    Bonjour,

    400 pas par mm, cela me parait beaucoup. Il faut regarder le pas des tes vis déja. 1,8° signifie que tu dois envoyer 200 pas pour effectuer une rotation complète de l'axe de ton moteur. regarde maintenant tes drivers pour déterminer le mode de micro pas réglé. full(200) 1/2(400) 1/4(800) etc...

    Pour la vitesse, 2500mm/mn euhh essaye déja à 1000mm/mn :) J'ai l'impression que tes moteurs ne suivent tout simplement pas. Et après tu augmentes jusqu'au décrochage et tu baisses ton réglage à -30% de la vitesse limite.
     
  4. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Ma CNC 6040
    Salut ctoutmoi,

    Alors j'ai déjà pas beaucoup de cheveux, mais je crois que ce soir j'en ai plus ! :mad:

    Tu as parlé du réglage de mes drivers pour les micros pas :shock:
    Je suppose que ça se trouve sur les cartes dans le boitier. Je fais une photo et reviens.
    A noter, je n'ai pas de doc pour ces cartes...
    A de suite !
     
  5. yves90

    yves90 Nouveau

    Messages:
    40
    Inscrit:
    23 Septembre 2010
  6. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Ma CNC 6040
    J'ai essayé tes paramètres aussi yves90, sans succès.

    Des fois les axes veulent bouger comme il faut, alors je saute de joie tout en maintenant la touche de déplacement d'un axe, mais après 10cm de course, c'est la fin et la ... :cry:

    ctoutmoi, voici une photo d'une de mes cartes d'axe (j'en ai 4)
    [​IMG]


    Comme je remets tout en question, j'ai reformaté mon PC 1.67GHz avec 1Go de vive...
    En attendant une réponse, je retourne à mes essais... :cry: :cry: :cry:
     
  7. tourniquet

    tourniquet Ouvrier

    Messages:
    497
    Inscrit:
    14 Décembre 2008
  8. ctoutmoi

    ctoutmoi Ouvrier

    Messages:
    479
    Inscrit:
    15 Janvier 2008
    Localité:
    Cabries (A côté d'Aix en Provence...)
    Ma CNC 6040
    Wouah les connecteurs :sad: Bon c'est une carte à base du TB6550 qui peux fonctionner en micros pas. Tu le détermines par les 4 micro switches en haut à gauche. Pour ça il te faut la notice donc.
    Stp, mesure le pas de tes vis à billes.
    Autre question, les moteurs sont il accouplés directement au vis ou il y à une transmission poulies courroies ?
     
  9. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Ma CNC 6040
    mes connecteurs sont si moches que ça ? :???:
    je vais voir avec le vendeur pour la notice.

    En ce qui concerne les vis à bille, le pas est de 5mm et l'accouplement est directement moteur/vis

    Alors, j'ai fait plusieurs essais mais rien n'y fait, je commence à me poser des questions...

    J'ai démonté un moteur de son support et l'ai fait fonctionner à vide pour voir si il y avait une différence, mais rien...
    ça broutte, ça broutte, ça broutte
    Et ça sur tous les axes !
    Hier j'ai fait des essais à la fin de la configuration de mach3 comme indiqué dans la notice et il y a eu des moments ou les axes bougeaient bien pendant les tests, pas longtemps, mais de manière fluide...

    Moi qui voulait faire un petit truc à ma chère et tendre avec, je sens le truc bien compromis !
     
  10. Doctor_itchy

    Doctor_itchy Modérateur

    Messages:
    3 554
    Inscrit:
    20 Avril 2007
    Ma CNC 6040
    question a deux balle

    le reglage du courant dans les bobine du moteur est bon ?

    genre si il est regler a 400ma et que le moteur est un 2.3A forçement que ça va pas bien tourner ^^

    trouve la notice , verifier tout les reglage drivers , verifie aussi que la tension d'alim est proche de la tension max que le drivers accepte (tension max du drivers -5volt = tension a appliquer au drivers ! )

    si tjrs rien , verifier le branchement moteur une bobine par pont ( double pont en H controleur bipolaire ! )

    bonne "merde" :)
     
  11. Telerotor

    Telerotor Nouveau

    Messages:
    22
    Inscrit:
    7 Septembre 2009
    Ma CNC 6040
    Salut!

    J'ai la meme machine, je te donne la liste des réglages qui fonctionne très bien avec la mienne:

    Dans Mach3 Motor Tuning:

    X&Y
    Steps Per: 320
    Velocity: 1500
    Acceleration: 120
    Step Pulse : 2
    Dir Pulse : 2

    Z
    Steps Per: 320
    Velocity: 800
    Acceleration: 60
    Step Pulse : 2
    Dir Pulse : 2

    Dans le boitier commande:

    XYZ
    Reduction du courant : OFF
    Reglage Micro pas: Full Step
    Courant des Axes: 3.1A (100%) (d'origine ils etaient sur 2.3A mais les moteurs perdaient des pas. Depuis que j'ai augmenté plus de soucis!!)
     
  12. yves90

    yves90 Nouveau

    Messages:
    40
    Inscrit:
    23 Septembre 2010
    Ma CNC 6040
    Petite question, je ne suis pas expert donc je cherche à comprendre :

    Comment peux tu régler le nbr de pas par tour a 320 pour un moteur qui en à 200 ?
    J'ai déjà fait ce type d'essais sa marche sans problème mais chez moi les cotes ne sont plus du tout exactes. Par contre c'est vrai que dans certain mouvement c'était mieux.

    Yves
     
  13. Telerotor

    Telerotor Nouveau

    Messages:
    22
    Inscrit:
    7 Septembre 2009
    Ma CNC 6040
    Mmmm c'est très juste!
    J'ai vérifie mais effectivement je n'ai pas les mêmes moteurs! Ne tiens pas compte des réglages dans Mach!
     
  14. dh42

    dh42 Compagnon

    Messages:
    3 975
    Inscrit:
    4 Septembre 2009
    Localité:
    Près de St Etienne (42)
    Ma CNC 6040
    Bonjour à tous

    Yves90: Steps per ne représente pas un nombre de pas par tour, mais de pas par mm.

    ex: vis au pas de 5mm en prise directe et moteur 200 pas/tr -> il faut 200 pas pour avancer de 5mm (donc faire un tour complet) soit 200/5=40 pas/mm en "Full step"

    soit le double (80) si tu est en demi pas, 160 en quart de pas, 320 en 1/8 de pas ... etc

    tu peux ensuite finir la calibration précise avec l'utilitaire "set steps per unit" du panneau "Settings" de Mach3 (bouton en bas à gauche)

    ++
    David
     
  15. yves90

    yves90 Nouveau

    Messages:
    40
    Inscrit:
    23 Septembre 2010
    Ma CNC 6040
    oK? La je comprends mieux. Merci pour cette explication, mais je ne travail plus sous Mach3 (que j'appréciais beaucoup pourtant) je bosse avec GalaaD désormais en USB.

    Yves
     
Chargement...

Partager cette page