1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Installation d'une expresscard 'True PCI-E'

Discussion dans 'EMC2 / LinuxCNC' créé par xest, 8 Mai 2012.

  1. xest

    xest Nouveau

    Messages:
    40
    Inscrit:
    25 Mars 2012
    Installation d'une expresscard 'True PCI-E'
    Bonjour à tous,

    Je vous détaille mon problème, j'ai dans les mains une expresscard Dexlan ("Port parallèle True PCI-e") que j'essaye de faire fonctionner sur mon vaio VGN-FW21E, sous Linux 10.04.

    Mais premiers pas sous Linux = je galère pas mal pour installer les drivers fournis, sont-ils d'ailleurs bien nécessaires pour faire fonctionner EMC2 ? Un sujet est ouvert sur linuxcnc, qui semble correspondre au mien (moschip 9901) : http://www.linuxcnc.org/index.php/english/component/kunena/?func=view&catid=18&id=15955
    "If it is a parallel port card, the drivers supplied will not work with EMC and you don't need them."

    A priori ma carte est détectée :

    04:00.0 Parallel controller: NetMos Technology Device 9900 (prog-if 03)
    Subsystem: Device a000:2000
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 4
    Region 0: I/O ports at b010
    Region 1: I/O ports at b000
    Region 2: Memory at d2901000 (32-bit, non-prefetchable) [size=4K]
    Region 5: Memory at d2900000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>

    Si je n'ai pas besoin de drivers, de quoi ai-je besoin ?
    Il semble donner une solution dans le sujet outre manche, mais je pédale déjà pas mal en français, alors un dépannage anglophone, bonjour :roll:

    Merci d'avance, et mes excuses pour ces questions de novice. :wink:
     
  2. jcma

    jcma Compagnon

    Messages:
    1 658
    Inscrit:
    2 Novembre 2008
    Localité:
    Mulhouse - Haut-Rhin
    Installation d'une expresscard 'True PCI-E'
    Bonjour,

    Je ne sait pas si cela peut t'aider.

    Sur le lien donné, l'auteur ne donne pas la maniére qu'il a utilisé pour resoudre son probleme. D'apres l'intervenant, le pilote n'est pas requis et il suggere d'utiliser pncconf pour tester les adresses utilisées par la carte // (parport).

    Dans ton cas les 2 adresses du port parallele sont 0xb000 et 0xb010 (Au lieu de 0x5000 et 0x5008 du post).

    @+
    Jean-Charles
     
  3. xest

    xest Nouveau

    Messages:
    40
    Inscrit:
    25 Mars 2012
    Installation d'une expresscard 'True PCI-E'
    Salut jcma,

    Merci pour ton aide, du coup impossible d'avoir le fin mot de l'histoire avant d'avoir le reste de l'électronique en ordre de bataille :| Je repasserai par là quand ce sera le cas. :-D
     
  4. xest

    xest Nouveau

    Messages:
    40
    Inscrit:
    25 Mars 2012
    Installation d'une expresscard 'True PCI-E'
    Verdict, si ça peut être utile à quelqu'un aussi doué que moi :mrgreen: : il suffit de filer à EMC2 le bon port (ici 0xb010) trouvé via 'lspci -vv' pendant la config, et ça fonctionne, pas besoin d'installer de pilote ou apparenté.
     
Chargement...

Partager cette page