1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

F word missing with inverse time g1 move on Line number #6

Discussion dans 'Mach' créé par eric356, 7 Février 2011.

  1. eric356

    eric356 Apprenti

    Messages:
    197
    Inscrit:
    16 Décembre 2010
    Localité:
    belgique
    F word missing with inverse time g1 move on Line number #6
    le soucis est dans le titre .....
    j'utilise deux pc un avec lequel je dessine et je prépare mes programmes , et le second avec lequel je fais tourner la machine ....
    lorsque je prend un programme simple comme celui ci

    G90 G40 G17
    T1 M6
    G0X0 Y0 Z10
    M3 S1000 F1000
    G0X10 Y-10 G41
    G0 Z0
    G01 Z-6
    G01 Y-4.25 X7.5
    G02 Y-3.87 X5.75 I7.5 J0
    G03 Y-3.87 X-5.75 I0 J-16.64
    G02 X-4.05 Y2.49 I-7.5 J0
    G03 X4.05 Y2.49 I0 J5.41
    G02 X5.75 Y-3.87 I7.5 J0
    G01 Y-10
    G00 X10 Z10
    M30

    il fonctionne parfaitement avec la machine , par contre avec le pc de test il ne fonctionne pas et j'ai cette erreur qui se marque ????
    que cela peut-il être ?
    j'ai l'impression que j'ai modifier un paramètre quelque part mais je ne vois pas lequel ????
    zavez une idée .... ca me tracasse.... :???:
     
  2. eric356

    eric356 Apprenti

    Messages:
    197
    Inscrit:
    16 Décembre 2010
    Localité:
    belgique
    F word missing with inverse time g1 move on Line number #6
    une tite info l'erreur change de ligne lorsque j'ajoute l'avance F dans le ligne voulue ...comme si je devais réintroduire l'avance à chaque ligne.
     
  3. valentin

    valentin Compagnon

    Messages:
    608
    Inscrit:
    30 Juillet 2008
    Localité:
    pas de calais france
    F word missing with inverse time g1 move on Line number #6
    bonjour
    essai sans le G41
    donc sans compensation pour voir
    car je pense qu il naime pas etre en compensation avec une remontee en Z

    +++
     
  4. valentin

    valentin Compagnon

    Messages:
    608
    Inscrit:
    30 Juillet 2008
    Localité:
    pas de calais france
    F word missing with inverse time g1 move on Line number #6
    re
    normalement ce message est dut aussi a un G93
    essai de taper G94 en mode MDI

    +++
     
  5. jo32

    jo32 Nouveau

    Messages:
    29
    Inscrit:
    19 Octobre 2010
    Localité:
    Hainaut (Belgique)
    F word missing with inverse time g1 move on Line number #6
    Bonjour eric356

    Puisque le même programme fonctionne avec l'un des PC(s) et pas avec l'autre, ce n'est donc pas le G-Code qui est en cause.

    Si tes versions de Mach3 sont les mêmes dans les deux PC(s), essaie en remplaçant simplement le fichier "Mach3Mill.xml" dans ton PC de test par celui qui se trouve sur ton PC machine.
    Tu retrouveras alors des configurations et des paramétrages absolument identiques dans les deux ordis et ça devrait probablement résoudre ton problème.

    PS: je viens de charger ton programme, et chez moi Mach3 ne me signale aucune erreur (j'ai fait un essai sur 2 PC).
     
  6. yannick622

    yannick622 Apprenti

    Messages:
    192
    Inscrit:
    4 Mars 2009
    F word missing with inverse time g1 move on Line number #6
    cette erreur apparait quand la machine se trouve dans le mode temps inverse (g93) est que qu'une ligne avec g1,g2,g3 n'a pas de mot F.
    voir la doc page 10.36.

    essaie de rajouter g94 sur ta premiere ligne pour definir un mode d'avance en unité par minutes. theoriquement un g93,g94,g95 devrait apparaitre afin de definir le mode d'avance.
    si ta machine etait en g93 et qu'il n'y a pas de g94 ou 95 pour l'annuler alors elle reste en g93.

    essaie ca tu verra.
     

Partager cette page