1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Des vagues sur l'axe y avec linuxCNC

Discussion dans 'EMC2 / LinuxCNC' créé par niala003, 6 Mars 2015.

  1. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Bonjour,

    Merci pour un petit coup de main, je suis un debutant.

    Mon probleme est que ma machine ( fait maison) sculpte correct pour l'axe x (profondeur et distance) correctement.
    Mais sur l'axe de y (distance ok) la tete de la toupie de fois ne descent pas assez (sur toute la largueur), elle peut le faire 6 a8 ( variable) fois et hop elle descent correct comme demender ( sur l'ecran le z=0 correctement ou + si c'est le dessin a graver, mais affiche 0 si elle doit etre a 0 mais la tete n'est pas a 0). La tete de la toupie ne descent jamais trop bas, elle peut faire une exemple 20 passes ok, 8 fois .3mm trop haut, 10 ok, 4 de .4mm haut, 6 de .6mm haut et revenir a la bonne profondeur, tous ca avec le z=0 sur l'écran
     
  2. brise-copeaux

    brise-copeaux Compagnon

    Messages:
    7 343
    Inscrit:
    5 Janvier 2007
    Localité:
    Rouen Normandie-76- ou Bagnole de l'orne -61-
    Des vagues sur l'axe y avec linuxCNC
    Salut,

    Avec un tel exposé, je crains qu'il y est pas beaucoup de réponse...moi j'ai rien compris :smt017

    @ +
     
  3. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Bonjour,

    je m'explique la toupie est deplacer sur l'axe y=0 et x=0 et descent z=0 , la toupie est depance a y=0 et x=150 , rendu a x=150 elle se deplace a y=1 x=150 et redepart pour aller a y=1 x=0 sans changer z=0 mais lorsqu'elle se deplace pour y=2 x=0 la tete de la toupie est un peu plus haute de 1mm sans changer a ecran ( sur l ordinateur ) elle fait donc en passe avec une hauteur de 1mm plus haut que les autres sans demander.
     
  4. gaston48

    gaston48 Compagnon

    Messages:
    6 193
    Inscrit:
    26 Février 2008
    Localité:
    59000
    Des vagues sur l'axe y avec linuxCNC
    Bonjour,
    Essaye déjà de permuter les moteurs X et Y en faisant attention aux courses qui ne sont plus configurées,
    pour voir si le problème se reporte sur l’axe X. Cela éliminera déjà un problème mécanique.
    il faut voir si tu n’as pas un parasitage de la voie Z quand Y est actif.
     
  5. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Non mon probleme ressemble a des pertes des pas manquant.
    le système affiche le message suivant a l'ouverture du programme .RTAPI:error Unexpected realtime delay on task 1 This message will only display once per session. Run the latency test and resolve before continuing, Unexpected realtime delay check dmesg for détails.
    je fait le teste de latency et le système m'afficje 11386 en fessant fonctionner plusieurs programme mais lorsque je demarre pour aller sur internet OP dans les 100 000.
    j'ai installer linuxCNC 2.7 et on peut changer les priorités du noyau de linux donc je pourrai enlever la priorité de l'ouverture internet ???? ou enlever ce programme d'ouverture d'internet ( j'ai 3 autres ordinateurs pour aller sur internet ) ???????
    Mais comment faire.
    Merci Bien
     
  6. gaston48

    gaston48 Compagnon

    Messages:
    6 193
    Inscrit:
    26 Février 2008
    Localité:
    59000
    Des vagues sur l'axe y avec linuxCNC
    Ou il faut réserver ta machine exclusivement à linuxcnc en cour d’usinage.
    Des accès internet avec pubs ou autres multiplie pas 10 le temps de latence.
    Si tu sors avec de haute fréquence comme avec une grande résolution en micropas,
    tu peux doper le port parallèle par une carte Mesa electronics type 7i43 plus une 7i42TA de protection

    Ca a pris une claque avec le change malheureusement…
    http://www.duzi.cz/shop_cnc/index.php?main_page=index&cPath=1_4
     
    Dernière édition par un modérateur: 16 Avril 2015
  7. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Merci Gaston48
    mais c'est un peut et meme tres compliquer ces installations de ces correcteurs (mais s'il le faut je vais essayer )
    Et oui cette ordinateur n'est que pour linuxcnc et j'ai réinstaller les fils avec les pins ( car la personne qui l'as fait n'as pas respecter les pins pour xyz comme leurs models d'installation) et réessayeras demain.
    Mais il y as t'il une carte mère qui serais correcte et qu'elle serais la meilleurs ( qu'elle avez-vous sur votre machine ) j'en achèterais une.
    j'essaye et je vous donne des nouvelles.
    Merci
     
  8. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Bonjour Gaston48
    Les testes n'ont pas changer grand chose, meme si j'ai changer les connections sur les broches donc la 2 avec pas de x, 3 avec direction x , 4 et 5 pour y et 6 et 7 avec z .
    Tous sont connecteur avec une ( PC Breakout Board DB25) qui se connecte avec des Stepper Motor Driver DQ542MA ( les switch Off Off On Off Off Off On Off) ( 2.37 PEAk 1.69 RMS).
    j'ai eu les 2 memes messages d'erreurs au demarage (ceux citer dans un message precedent) et un autre lorque la machine marchais, celui-ci (le mouvement linear de la ligne 0 va dépasser la limite de la jointure 2'S )

    Pour le teste latente qui est a 9 000 a 12 000 meme si j'Applique des programme ( si cliquer sur le logo de Firefox) et ne bouge pas bien bien.
    si je désinstaller Firefox et d'autre programme ( car je n'utilise cette ordinateur que pour CNC.) cela pourrais t'il regler un probleme.
    Autre question restez-vous dans la province de quebec, si oui votre numéros de téléphone pour que je vous appel mon é-mail est niala003zz@hotmail.com
    Merci bien
     
  9. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
  10. gaston48

    gaston48 Compagnon

    Messages:
    6 193
    Inscrit:
    26 Février 2008
    Localité:
    59000
    Dernière édition par un modérateur: 16 Avril 2015
  11. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Bonjour
    Bon j'ai changer d'ordinateur dont celui-ci répond tres bien ( 25394 ns meme en couvrant des programme et en me connectant sur internet)
    C'est une carte mère Foxconn 661FX7MF-S - Intel® Pentium® 4 processors, Socket T (LGA775)
    - FSB 800 / 533MHz
    - Single Channel 400MHz / 333MHz / 266MHz DDR SDRAM
    - Serial ATA x 2
    - 5.1 channel, AC’97 (Realtek)
    - 10/100 Mbps LAN (IC Plus)
    - 8 USB 2.0/1.1 ports
    Donc pour commencer, comment metteriez-vous les switch sur les steepper motor (un Wantai DQ542MA) avec des moteurs Wantai Nema 23 wt575th115-4204a.
    S.V.P. les SW1, SW2 SW3 ET LA SW4 ( je présume off) et les SW5, 6, 7 et la SW8 quel position avec la carte mere cité plus haut.
    Merci
     
  12. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
  13. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Des vagues sur l'axe y avec linuxCNC
    Nouvelle essaie configurer Off Off On Off et pour sw5,6,7 et Off Off On On pour 1600 pulse
    Plus d'erreurs RTAPI avec BASE_PERIOD_Maximun de 27150 et avec le nouveau ordi et des vitesses de deplacement pas vite.
    Mais encore des ligne de l'axe des X plus haute des d'autres.
    C'est a dire depart de x=0, y=0 pour aller a x=300, y=0 et avec z=-1 cette ligne est belle
    Mais la ligne apres de x=300, y=1 pour aller a x=0,y1 et z=-1 mais la position reel de z est 0 (a l'écran c'est écrit -1)
    elle peut faire cela 2 3 et 4 fois de suite et revenir a la position correct après pour 50 et meme 75 fois correct
    Donc une ligne de l'axe X que l'axe z monter pour faire une forme cette forme est aussi plus haute que ce qu'elle devrait.
    Donc Est-ce une perte de pul ou debalancement de ma tete de toupie.
     
  14. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Dernière édition par un modérateur: 16 Avril 2015
  15. niala003

    niala003 Nouveau

    Messages:
    23
    Inscrit:
    20 Avril 2014
    Dernière édition par un modérateur: 16 Avril 2015
Chargement...
Articles en relation
  1. grandioso
    Réponses:
    2
    Affichages:
    496
  2. gtt38
    Réponses:
    7
    Affichages:
    1 347

Partager cette page