1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Cycle de percage en spirale

Discussion dans 'CamBam' créé par jnbatisse, 1 Juillet 2015.

  1. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
    Cycle de percage en spirale
    Comme le titre l'indique je rencontre un problème de cycle de perçage en spirale, en effet le trou n'est pas circulaire, sur mon ancienne machine ça fonctionnait parfaitement, et là ça ne le fait plus, à votre avis est ce que ça peut venir de ma config, sachant que le reste à l'air de fonctionner normalement (même si je n'ai pas pu tester toutes les fonctions bien sur).
     
  2. kiki86

    kiki86 Compagnon

    Messages:
    2 643
    Inscrit:
    7 Janvier 2015
    Localité:
    Maisons Alfort
    Cycle de percage en spirale
    bonjour
    peux tu etre plus clair avec un dessin
    qiue veux tu dire par "trou n'est pas circulaire"
    A+
     
  3. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
  4. speedjf37

    speedjf37 Compagnon

    Messages:
    981
    Inscrit:
    15 Octobre 2009
    Localité:
    indre et loire
    Cycle de percage en spirale
    Bonjour,

    Quel logiciel de pilotage ?

    Pistes :
    Pertes de pas sur un axe bruit bizarre ?

    Problème de paramètres sur les axes (pas la même course sur les X Y).
    Problème de jeu (backslash) sur un axe
    Problème de jeu (dur) sur un axe
    Entrainement desserré.

    Vérifier que les courses sont bonnes 100mm logiciel = 100mm déplacement et retour à 0 (même en forçant)

    Cordialement JF
     
  5. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
    Cycle de percage en spirale
    tout est nickel de ce coté, j'ai déjà fait bon nombre d'usinages nécessitant de la précision, et je n'ai pas de problèmes aussi bien en poche qu'en gravure et détourage, le problème ne se pose que lors des cycles de perçage en spirale.
    Je génère avec cambam et je pilote avec Linux CNCje me demande si ça n'est pas un problème de paramétrage de mes driver DM542A au niveau de StepConf dans LinuxCNC.

    Voir mon sujet : http://www.usinages.com/threads/parametrage-linuxcnc-avec-driver-dm542a.78686/
     
  6. dh42

    dh42 Compagnon

    Messages:
    3 978
    Inscrit:
    4 Septembre 2009
    Localité:
    Près de St Etienne (42)
    Cycle de percage en spirale
    Salut,

    Ce qui est sur, c'est que si tu dessine un cercle dans CB, le Gcode produit correspond bien à un cercle, donc ça ne viens pas de CB lui même.

    Les problèmes que j'ai rencontrés avec le perçage en spirale pour ma part, c'est des pertes de pas dues au fait que les 3 axes soient utilisés simultanément.

    Dans mon cas, elles se produisaient sur le Z si la vitesse d'avance était trop élevée. Dans un premier temps, j'ai solutionné le problème en réduisant la V d'avance, puis dans un 2ieme temps en remplaçant mon alim ; apparemment trop faible pour nourrir 3 moteurs utilisés intensivement de manière simultanée, surtout si la spirale avait un faible diamètre et un pas important (genre tire-bouchon) ... peut être à tu un pb similaire.

    ++
    David
     
  7. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
    Cycle de percage en spirale
    le problème vient de ma config machine sous linuxcnc en effet je grave de petites étiquettes, et toutes les lettres arrondie comme le S ou le D présentent des déformations dans les partie arrondies
     
  8. dh42

    dh42 Compagnon

    Messages:
    3 978
    Inscrit:
    4 Septembre 2009
    Localité:
    Près de St Etienne (42)
  9. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
    Cycle de percage en spirale
    voila pour illustrer le problème que je rencontre
    a gauche des gravure avec mon ancienne machine (idcnc tu connais il me semble :wink:) et a droite le même programme avec ma nouvelle une TRON+
    se sont des étiquettes qui mesurent 22x22mm pour donner l'echelle

    20150704_001359.jpg 20150704_001342.jpg
     
  10. dh42

    dh42 Compagnon

    Messages:
    3 978
    Inscrit:
    4 Septembre 2009
    Localité:
    Près de St Etienne (42)
    Cycle de percage en spirale
    même vitesse d'usinage pour les 2 ? ou tu va plus vite avec la Tron ?
     
  11. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
    Cycle de percage en spirale
    j'ai essayé moins vite, même vitesse et plus vite, j'ai essayé plusieurs micro pas différents et changer les paramètres des temps et accélération dans linuxcnc, pour un résultat identique
    j'ai fait d'autre usinages sans soucis, mais j'ai l'impression que dés que c'est "petit", ça déconne
     
  12. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
  13. dh42

    dh42 Compagnon

    Messages:
    3 978
    Inscrit:
    4 Septembre 2009
    Localité:
    Près de St Etienne (42)
    Cycle de percage en spirale
    Ah, si tu est en port //, il faut du 32 bits (XP ou 7), si tu est en USB, il faut le driver (plugin) approprié, mais ça marche sur les systèmes 64bit (c'est juste le pilote du port // qui ne fonctionne pas en 64bits, pas Mach3 lui même)

    Tu n'aurais pas un problème de rigidité au niveau du Z ; même si j’imagine que ça ne force pas beaucoup en gravure.

    On dirait que la barre horizontale du haut du D n'est pas horizontale et que la jonction en bas à gauche du D n'est pas correcte non plus ... pertes de pas ? flexions ?

    Tu a tenté le mode Exact stop pour voir ? (désactiver la vitesse constante)

    Je sais que sur linux CNc il y a un réglage permettant de définir la précision de suivi du mode vitesse constante ; c'est peut être une piste ...

    http://www.usinages.com/threads/les-plugins-et-scripts-pour-cambam.78213/page-2#post-881027

    ++
    David
     
  14. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
    Cycle de percage en spirale
    apres un nombre d'essai incalculable sans aucune avancée réelle, je décèle un léger jeu sur les bague de glissement igus sur mes axes Y et Z, demain je vais essayer de tirer ça au clair.
     
  15. jnbatisse

    jnbatisse Apprenti

    Messages:
    178
    Inscrit:
    26 Février 2009
    Localité:
    Liverdy en Brie - 77
Chargement...
Articles en relation
  1. sergio26
    Réponses:
    31
    Affichages:
    4 209
  2. jigour
    Réponses:
    5
    Affichages:
    958
  3. uster81130
    Réponses:
    10
    Affichages:
    230
  4. lublub
    Réponses:
    15
    Affichages:
    1 488
  5. jeramenemafraise
    Réponses:
    2
    Affichages:
    1 019

Partager cette page