[CNCDIY, WALTER 6545] mise en route

Discussion dans 'Fraiseuses CNC industrielles de type portique' créé par catlord, 16 Novembre 2011.

  1. catlord

    catlord habitué

    Messages:
    209
    Bonjour à tous :)
    premier message sur le forum pour présenter ma bestiole que beaucoup connaissent.
    Je suis "concepteur" de châssis de drone multirotors (il y en a un autre qui trainouille sur le forum :p). Je fait des châssis en aluminium qui ressemble à ça:
    [​IMG]
    Mon objectif c'est de pouvoir faire des protos avant d'envoyer une production plus importante en découpe laser.
    je compte utiliser de l'alu 7075 en 1.5mm d'épaisseur.

    J'ai acheté une CNC 6545 chez CNC DIY. il y a deux mois et je viens enfin d'avoir un peu de temps pour la monter...
    J'ai fait le montage sans soucis, le guide pour le chemin de câble était monté du mauvais coté de la machine mais rien de bien grave.

    J'ai checké les pôles des moteurs pour vérifier que ceux-ci étaient bien sur les pinouilles 1/2 et 3/4 => tout nickel de ce coté là aussi :)

    La broche est par contre livrée avec un connecteur non adapté au boitier, heureusement ils fournissent un connecteur qui va bien (à monter soi même).
    J'ai monter la machine sur un vieux tiroclass bien bien lourd (au moins autant que la machine elle même ^^) avec un tapis anti-vibrations en dessous.
    [​IMG]
    les soucis ont commencé après :D

    J'ai installé Mach3 en version d'évaluation pour commencer (je compte prendre la Vf + license chez mach3fr :wink: ) j'ai essayé de suivre les infos donné dans les docs de chez CNC DiY mais ç'est .. pas super clair :)

    Voici mon boitier (avec écrit BORSCH en gros dessus) je suis censé avoir une walter 6545, pas une borsch , broche VFD 1.5Kw mais le boitier présente tout la connectique qui va bien derrière:
    [​IMG]
    [​IMG]

    la config sous mach3 que j'ai utilisé est la suivante:

    Kernell speed 35000



    j'utilise la raquette de commande qui va bieng (USB manual remote controler) et qui semble a priori fonctionner.(l'axe Y répond bien en tout cas cf la suite :D)

    Bon passons aux soucis :D
    je n'ai qu'un seul axe qui fonctionne l'axe longitudinal (Y) et il ne fonctionne que dans un sens.
    +Y ou -Y pour lui c'est pareil => il va en direction du moteur.

    Résolu avec la config ci dessus
    La broche: impossible de la faire tourner, bref ça commence mal si je n'arrive déjà pas à faire fonctionner les moteurs correctement.
    résolu avec config ci dessus

    Attention, à l'heure de cette publication, l'optimisation de la broche est encore en cours.

    Je vais essayer de me pencher plus avant dans la config de Mach3 mais je découvre ce vaste monde CNCesque, et la route semble ardue.
    Si d'aventure une âme charitable ayant les connaissances et les compétences idoines passe par le 91, elle sera bien accueillie (avec une bonne bouteille de Sauterne :D)
    Résolu, âme MEGA charitable trouvé en la personne d'Ewidance :)

    Je continuerais bien sur à décrire mes aventures sur ce sujet :)

    CONFIG CNC WALTER 6545.JPG

    WALTER 6545 CONFIG 2.JPG
     
  2. catlord

    catlord habitué

    Messages:
    209
    Je compte utiliser ce topic pour détailler mes "progrès".
    voici donc ce que j'ai trouvé ce soi, un peu de lecture:

    trois topic qui cause de machines identiques à la mienne.

    http://www.cnczone.com/forums/chinese_m ... _dead.html
    http://www.cnczone.com/forums/benchtop_ ... ems-2.html
    http://www.woodworkforums.com/f170/my-c ... ndex5.html

    On y apprends que l’assignation des pins n'est pas la même que dans la doc, que le port // n'apporte pas assez de jus dans le contrôleur et qu'il faut lui mettre le cable USB (me semble pas avoir vu de port usb sur a carte ...)

    d'aprèsce post la config pour les moteurs est la suivante:
    la suite demain :)
     
  3. catlord

    catlord habitué

    Messages:
    209
    Bon j'ai essayé ces settings et rien de rien.
    je m'interroge sur le fonctionement ou pas de mon port paralelle.
    Il y a a priori avec mach3 un diagnostique disponible cf:
    http://www.woodworkforums.com/f170/my-c ... ost1394385

    je regarde ça demain.
    ce post est super enrichissant :)
     
  4. Adrenaglisseman

    Adrenaglisseman habitué

    Messages:
    87
    Localité:
    Montigny le Bretonneux (yvelines)
    Bonjour, tu as un PC de bureau ou un PC portable pour ta cnc?
     
  5. catlord

    catlord habitué

    Messages:
    209
    Bonjour,
    j'ai un pc desktop (de bureau donc)
    J'ai pu voir sur cette doc:
    http://ustep.homecnc.fr/download/3axis/3axis_doc.pdf

    qu'il faut un câble parallèle droit et non pas croisé pour fonctionner avec la carte décrite.
    J'imagine que cela doit être la même chose sur la mienne.
    Ce matin je test:
    - si mon câble est un câble droit ou croisé
    - le système de contrôle qui est avec mach3

    Le fait de changer l'assignation de pin du câble à la volée c'est dangereux pour la carte drivers ou pas ?
    Fait tourner la broche vfd quelques secondes pour tester sans qu'elle soit refroidie par eau c'est dangeureux pour la broche ?

    Je préfère poser les questions avant de faire une boulette :)
     
  6. ewidance

    ewidance à définir

    Messages:
    256
    Localité:
    Montpellier
    RIen de dangereux dans le fait de changer l'assignation du port parallèlle. Par contre, faire tourner la broche VFD qq secondes ou qq minutes, ok, mais vraiment pas plus car sans refroidissement cela chauffe vite.

    Je t'encourange à démonter le boitier de commande (après avoir tout démonté...) et :
    1/ Vérifier que tous les connecteurs snt correctement enfichés. Pour ma part, 2 étaient déconectés dans le transport.
    2/ Faire des photos et les publier pour que l'on voit quelle cartes tu as dans le boitier
    3/ Faire une photo en macro de la sérigraphie de la breackout board et d'une des cartes de pilotage d'axe.
    4/ Relever le câblage de la breakout aux cartes d'axes.

    J'ai mise en route une Borch9060, donc si je peux t'aider, ce sera avec plaisir. Si tu as skype et un webcam, cela peut se faire rapidement....

    Suite par MP si tu souhaites, mais soit ou WE seulement;
     
  7. nagut

    nagut pilier

    Messages:
    1 021
    Localité:
    ST-Claude Jura
    bonjour

    quelques secondes: non.
    je travaille avec des machines équipées de broches refroidies par eau (+ produit); 30 à 35000 trmn

    il arrive que le système de refroidissement déconne
    bon, si tu met 1 heures à t'en apercevoir: au revoir la broche et bonjour la séance au bureau

    daniel
     
  8. catlord

    catlord habitué

    Messages:
    209
    Merci à vous pour ces précieux conseils :)

    Voici les quelques photos que j'avais prise du boitier:





    J'ai quelques questions de gros gros débutant si cela ne vous ennuis pas:

    voilà, j'ai pu voir pas mal d'abréviations, de terme technique tel que BOB (pour désigner le boitier de contrôle de la machine ?), breakout board (carte de puissance ?), y a t il un petit glossaire dispo quelques part ? :)


    J'ai aussi acheter la carte sur port USB avec cette machine mais avant de la monter il me semblait judicieux de controler que tout fonctionne déjà sur port // :)
    @ewidance: grand merci à toi, mon skype: catlord21

    Cordialement,
    Cédric

    WP_000024 [1024x768].jpg

    WP_000023 [1024x768].jpg

    WP_000021 [1024x768].jpg

    WP_000022 [1024x768].jpg
     
  9. catlord

    catlord habitué

    Messages:
    209
    Voici une photo de mon câble parallèle:


    Je suis infoutut de dire si c'est un câble droit ou un câble parallèle ...

    Les deux traits rouges indiquent quel pin correspond a quel pin sur le mâle et la femelle.

    J'aurais tendance à penser qu'il est croisé parce que si je branche la partie haute (mâle) le pin en rouge en haut à droite sera sur la gauche de la prise en face.
    si je branche la partie femelle, le pin rouge en bas à droite sera situé en haut à gauche sur la prise en face.

    Edit: nan il doit être droit parce que les prises se font face :p
    donc ça colle.
    reste maintenant à tester le bazard pour trouver ces foutus pin de communications...

    WP_000029 [1024x768].jpg
     
  10. dyson

    dyson à définir

    Messages:
    271
    Localité:
    Bourgogne
    C'est bien un cable droit.
    Mais perso, je passerai directement en usb. Evidemment, il faut jouer du tournevis et de la pince coupante ce qui n'est pas forcémént évident si on débute dans ce domaine.
     
  11. catlord

    catlord habitué

    Messages:
    209
    Je n'ai pas de soucis avec pince coupante,tournevis et autre fer à braser, les multirotor que je montent sont autrement plus complexes :)
    par contre si je passe en USB et que ça ne fonctionne toujours pas, comment savoir i la boulette viens de mon montage ou du boitier ? D'où ma prudence en essayant de faire fonctionner le tout en //.

    Le passage en USB nécessite tout de même de passer par la case config et donc identifier les bons ports sous mach3.

    J'ai encore un peu de boulot cet après midi sur mes multirotors, j'attaque la CNC après :)
     
  12. catlord

    catlord habitué

    Messages:
    209
    la recherche progresse :)
    alors j'ai tester des pins au hasard et j'ai réussit à faire tourner l'axe x qui était sur le pin 2. En zieutant le tableau de config donné par cncdiy, j'ai tester toutes les config avec l'axe x en pin 2 et hop !
    le bon tableau correspond au tableau C,
    for CB-W4-001 (WALTER series controlers)


    bien c'est déjà ça qui fonctionne.

    Maintenant j'attaque deux trucs important:

    le bouton arrêt urgence sur le sommet du boitier: il ne fonctionne pas.
    deuxième truc un ptit moins important mais tout de même... la broche :D
    elle ne tourne pas du tout du tout.

    Ca me chiffonne parce que sur leur doc pour le bouton arrêt urgence il y une seule config pour tout les boitiers:
    port# 1 pin 10 active low.

    et bah ça marche pwint

    config cnc 6545 moteur output.jpg
     
  13. catlord

    catlord habitué

    Messages:
    209
    enfin ça marche pwint ...
    disons que orque j'appuie sur broche on (sur la télécommande), j'entends un truc qui se met sous tension comme si a broche tournait mais il ne se passe rien.
    ce n'est pas le bruit du moteur qui force hein, c'est un bruit de truc qui tourne mais ça tourne pwit.
    Je fait un chtiote vidéo et je mets en ligne.
     
  14. catlord

    catlord habitué

    Messages:
    209
  15. ewidance

    ewidance à définir

    Messages:
    256
    Localité:
    Montpellier
    Merci pour les photos. L'électronique n'est pas la même que la mienne. J'avais 4 cartes séparées pur les drivers, une carte breakout pourrie (l'interface parallèle) et une carte de commande de broche un peu différente, mais qui possède un afficheur à 3 Digits qui met la fréquence en hz de 0 à 400. L'alim était également différente. La mienne était à découpage 24V 12A.

    C'est d'ailleurs proprement câblé à coté de ce qu'il ma livré....

    Du positif, sur ta breakout board, il y a un petit connecteur pour mettre des limit switches. Il n'est pas équipé, mais cela peut se faire fastoche.

    Je ne vois pas ce que ventile le ventilo. Il n'est pas en face de la carte moteurs..

    Les 3 petits connecteurs de la break-out servent :
    * A l'alim 5v pour celui qui est le plus prêt du bord
    * A l'arrêt d'urgence, pour celui du milieu, muni d'un fil noir et rouge
    * Le troisième, le plus près du grand, sert au signal PWM qui pilotera la broche. Sur la mienne, il faut un signal de 10Hz PWM.

    Je vois sur la nappe qui relie la breakout à la carte moteurs, une sérigraphie près du grand connecteur.

    MASSE
    +5
    XC (axe X clock = pas)
    XD (axe X dir = direction)
    YC (idem pour axe Y)
    YD
    ZC (idem pour Z)
    ZD
    AC (idem pour A)
    AD

    Comme il n'y a aucune indication sur la sérigraphie sur l’assignation des broches du port //, j'ai peut qu'il faille le déterminer par l'expérimentation. Apparemment, on apprend de la nappe de liaison entre la carte puissance et la breakout qu'il n'y a pas d'enable pour les moteurs pas à pas. C'est un signal qui est normalement activé quand on sort du reset de Mach3. Les moteurs ne peuvent normalement pas tourner tant que ce signal est actif. D’où le fait qu'il faille d'abord le trouver pour que cela marche. ici, il semblerait que tu n'ait pas ce pb. C'est toujours un pb en moins.

    Mais repérer les signaux ne va pas être simple sans injecter un signal sur les entrées de la carte. Par contre, dans la doc de Mach3, tu as le schéma du port parallele. N'utilise que celles qui sont des entrées sur le rack. Cela te permettra de repérer les 4 entrées step, pius pas déduction les entrées Dir.

    Il restera ensuite à déterminer la sortie arrêt d'urgence du rack (qui est donc en entrée sur le PC) et l'entrée broche (qui est donc en sortie sur le PC).

    Mais si tu ne veux pas t'emmerder, demandes la dernière doc au gars de CNCDIY...

    image.jpg
     
Chargement...
Articles en relation Forum Date
[CNCDIY 3040] Bruit suspects en Y Fraiseuses CNC industrielles de type portique 21 Août 2012
Fraiseuse CNC Walter 6545 cncdiy Fraiseuses CNC industrielles de type portique 18 Juillet 2011

Partager cette page