1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

aide SVP probléme avec le post processeur "stagetool"

Discussion dans 'Siemens' créé par farhani123, 3 Avril 2012.

  1. farhani123

    farhani123 Nouveau

    Messages:
    1
    Inscrit:
    3 Avril 2012
    aide SVP probléme avec le post processeur "stagetool"
    bonjour à tous,
    J'ai un problème avec ma machine centre d'usinage "LERING" avec pupitre SIEMENS il ne prépare pas l'outil suivant à utiliser ce qui mène à une perte de temps.
    j'ai essayé d'identifier le problème et je trouve que c'est dans le post-processeur, pour être plus précis je trouve que il ya une fonction / variable appelée "stagetool" qui est définie comme ceci:

    stagetool: 1 # 0 = Ne pas pré-stade des outils, des outils de 1 étage =

    je l'ai trouvé égal à zéro, donc je le modifier à 1 ..
    cette modification de donne que le post-processeur préparer l'outil avec son numéro comme il est indiqué ci-dessous:

    O0000
    N100G0G90G54
    N102T="FR16"
    N104M6
    N106X-32.5Y-135.S2000M3
    N108Z5.T2 <-------------------"T2" c'est le numéro de l'outil suivants
    N110F500.

    le problème c'est que ma machine prépare l'outil s'il est appelé par son nom...donc ce que je veut faire c'est de savoir comment changer le numéro qui se trouve dans la variable "next_tool" par son nom...

    j'ais essayé plusieurs tentative mais j'ai pas pu résoudre cette problème.

    merci bien pour tous le monde de m'aider...
     
Chargement...
Articles en relation
  1. h-djamel
    Réponses:
    0
    Affichages:
    704
  2. Remyje66
    Réponses:
    4
    Affichages:
    1 606
  3. ericjaja
    Réponses:
    2
    Affichages:
    611
  4. le faucon
    Réponses:
    2
    Affichages:
    878
  5. julien7626
    Réponses:
    1
    Affichages:
    616

Partager cette page